<bdo id="w4eka"></bdo>
  • <table id="w4eka"><samp id="w4eka"></samp></table>
  • 小魔仙知識分享網

    通達信金牛趨勢買賣指標

    通達信金牛判勢指標源碼和機構震倉指標怎么寫,如下圖效果

    TJ:=FILTER(C,239)>0,NODRAW;
    TJJ:=SUM(TJ,0),NODRAW;
    TJA:=CONST(TJJ),NODRAW;
    C1:=CLOSE;
    V1:=TIME;
    A1:=COUNT(BARSCOUNT(C)=1 AND TIME<102000 ,0 );
    T:=IF(V1<130000,(FLOOR(V1/10000)-9.5)*60+(FLOOR(V1/100)-100*FLOOR(V1/10000)),
    (FLOOR(V1/10000)-11)*60+(FLOOR(V1/100)-100*FLOOR(V1/10000))),NODRAW;
    成交額:=AMOUNT,NODRAW;
    VV2:=SUM(AMOUNT,T),NODRAW;
    VV3:=VV2/T;
    SS:=IF(CAPITAL>150000000,0.3,IF(CAPITAL>20000000,0.5,IF(CAPITAL>10000000,0.8,IF(CAPITAL<200000,5,IF(CAPITAL<1000000,3,
    IF(CAPITAL<5000000,1.5,1)))))),NODRAW;
    VV5:=(REF(VV3,T-1)/CEILING(REF(VV3,T-1)/CAPITAL *10000+0.1))*SS,NODRAW;
    大額線:=IF(REF(VV3,T)=REF(VV3,T-1),VV5,REF(VV3,T)),NODRAW;
    起算量:=大額線*100,COLOR00FFFF,NODRAW;
    初正1:=IF(T=1 AND DYNAINFO(4)>=DYNAINFO(3),VV2,0);
    初負1:=IF(T=1 AND DYNAINFO(4)<DYNAINFO(3),VV2,0);
    初正:=SUM(IF(初正1>=大額線 AND T=1,初正1,0),T),NODRAW;
    初負:=SUM(IF(初負1>=大額線 AND T=1,初負1,0),T),NODRAW;
    初正2:=SUM(初正1,T),NODRAW;
    初負2:=SUM(初負1,T),NODRAW;
    T00:=IF(C1>REF(C1,1),0.9,-0.9);
    T01:=IF(C1<REF(C1,1),-0.9,0.9);
    T02:=T00+T01,NODRAW;
    TT1:=BARSLAST(CROSS(T02,+1.5)),NODRAW;
    TT2:=BARSLAST(CROSS(-1.5,T02)),NODRAW;
    TT:=IF(T02=1.8,1,IF(T02=-1.8,-1,0));
    正V1:=IF(TT=1 OR (TT=0 AND TT1<TT2),成交額,0),NODRAW;
    負V1:=IF(TT=-1 OR (TT=0 AND TT1>TT2),成交額,0),NODRAW;
    正負0:=IF(成交額!= 0 AND (正V1=0 AND 負V1=0),成交額,0);
    正V0:=IF(正負0!= 0 AND REF(正V1,1)!= 0 ,正負0,0);
    負V0:=IF(正負0!= 0 AND REF(負V1,1)!= 0 ,正負0,0);
    正V11:=正V1+正V0,NODRAW;
    負V11:=負V1+負V0,NODRAW;
    正V:=IF(正V11>=大額線,正V11,0);
    負V:=IF(負V11>=大額線,負V11,0);
    正V2:=IF(正V11<大額線,正V11,0);
    負V2:=IF(負V11<大額線,負V11,0);
    正總:=IF(TJJ<2,初正,0)+SUM(正V,T),NODRAW,COLOR0000FF;
    負總:=IF(TJJ<2,初負,0)+SUM(負V,T),NODRAW,COLOR00FF00;
    正總1:=IF(TJJ<2,初正2,0)+SUM(正V11,T),NODRAW,COLOR0000FF;
    負總1:=IF(TJJ<2,初負2,0)+SUM(負V11,T),NODRAW,COLOR00FF00;
    大差%:(正總-負總)/(正總+負總)*100,COLOR00FF00,NODRAW;
    小差%:(正總1-負總1)/(正總1+負總1)*100,COLOR00FF00,NODRAW;
    TJJB:=IF(FILTER(T,239)>0 AND TJA>1,REF((正總-負總),T),0),NODRAW;
    TJJJB:=SUM(TJJB,0)+IF(TJA>1,(正總-負總),0),NODRAW;
    TJJC:=IF(FILTER(T,239)>0 AND TJA>1,REF((正總+負總),T),0),NODRAW;
    TJJJC:=SUM(TJJC,0)+IF(TJA>1,(正總+負總),0),NODRAW;
    N今:TJJJB/10000,NODRAW;
    TJJJB/TJJJC*100,NODRAW;
    TJJB2:=IF(FILTER(T,239)>0,REF((正總-負總),T),0),NODRAW;
    TJJJB2:=SUM(TJJB2,0),NODRAW;
    TJJC2:=IF(FILTER(T,239)>0,REF((正總+負總),T),0),NODRAW;
    TJJJC2:=SUM(TJJC2,0),NODRAW;
    N昨:TJJJB2/10000,NODRAW;
    TJJJB2/TJJJC2*100;
    KL:=1;
    DRAWBAND(12000*KL,RGB(50,50,50),-5000*KL,DRAWNULL);
    Q4:=IF(大差%>=0,12000*KL,0),NODRAW;
    Q5:=IF(大差%>=0,-5000*KL,0),NODRAW;
    DRAWBAND(Q4,RGB(100,100,100),Q5,RGB(50,50,50));
    STICKLINE(CROSS(大差%,0),Q4,Q5,10,0),COLOR777777;
    STICKLINE(CROSS(0,大差%),Q4,Q5,10,0),COLOR777777;
    DIF:=EMA(CLOSE,20)-EMA(CLOSE,5);
    DEA:=EMA(DIF,10);
    MACD:=300*(DIF-DEA)*2/EMA(C,30);
    VARA:=EMA(REF(CLOSE,1),4);
    青山:=(SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100);
    綠水:=青山<3.5,COLORDBDBDB;
    火紅的:=FILTER(MACD<0 AND MACD>REF(MACD,1) AND 青山<20,5);
    太陽:=CROSS(青山,90),COLOR00FF00;
    DRAWBAND(IF((TJA<2 OR PERIOD!= 0),12000*KL,0),RGB(150,00,100),0,DRAWNULL);
    DD:=IF(MACD>=0,MACD,DRAWNULL)*1.5;
    STICKLINE(DD AND DD>REF(DD,1),0,DD*80*KL,4,0),COLOR0000FF;
    STICKLINE(DD AND DD<REF(DD,1),0,DD*80*KL,3,1),COLOR0000FF;
    IF(TJA<2,(青山-25)*150*KL,DRAWNULL),COLOR5BE000,LINETHICK6;
    DRAWBAND(IF((TJA<2 OR PERIOD!= 0) AND (青山-25)*1.5>0,(青山-25)*150*KL,0),RGB(00,200,50),0,DRAWNULL);
    DRAWBAND(0,RGB(00,180,120),IF((TJA<2 OR PERIOD!= 0),-5000*KL,0),DRAWNULL);
    ZJ2:=V/((H-L)*2-ABS(C-O));
    ZJ3:=IF(C>O,ZJ2*(H-L),IF(C<O,ZJ2*(H-O+(C-L)),V/2))+IF(C>O,0-ZJ2*(H-C+(O-L)),IF(C<O,0-ZJ2*(H-L),0-V/2));
    攻擊流量:=ZJ3/20/1.15;
    ZJ5:=攻擊流量*0.55+REF(攻擊流量,1)*0.33+REF(攻擊流量,2)*0.22;
    日流量:=EMA(ZJ5,3);
    STICKLINE(C>0 AND 日流量>=0,日流量,0,2,0),COLORFF38FF;
    STICKLINE(C>0 AND 日流量<=0,日流量,0,2,0),COLORFA3300;
    AR1:=LLV(LOW,10);
    AR2:=HHV(H,25);
    AR3:=EMA((C-AR1)/(AR2-AR1)*4,4);
    紅紅的天:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)
    -2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)
    -LLV(LOW,27))*100,5,1),3,1),LINETHICK0;
    IF((TJA<2 OR PERIOD!= 0) AND CROSS(紅紅的天,2),7000*KL,-5000*KL),COLOR0000FF;
    IF(紅紅的天>10,-5000*KL,DRAWNULL),CIRCLEDOT,COLORGREEN;
    IF(紅紅的天<=10,-5000*KL,DRAWNULL),CIRCLEDOT,COLOR0000CC;
    N:=IF(TJA<2 AND PERIOD=0,20,6);
    L1:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*200-60;
    有心就有:IF((TJA<2 OR PERIOD!= 0) AND CROSS(紅紅的天,2),7000*KL,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF77FF;
    好運!:IF((TJA<2 OR PERIOD!= 0) AND CROSS(紅紅的天,2),7000*KL,DRAWNULL),POINTDOT,LINETHICK4,COLOR00CCFF;
    STICKLINE(CROSS(3.5,AR3),10000*KL,12000*KL,2,0), COLOR00FFFF,LINETHICK2;
    STICKLINE(CROSS(AR3,0.3),-5000*KL,-3000*KL,2,0),COLORRED,LINETHICK2;
    DRAWTEXT(CROSS( 0,MACD)AND 青山>75 OR 太陽,9800*KL,'ヲ'),COLORDBDBDB;
    DRAWTEXT(綠水,-3000*KL,'ャ'),COLORDBDBDB;
    DRAWTEXT(綠水,-3000*KL,'︼'),COLOR688EC1;
    IF(PERIOD=0,2500,DRAWNULL),COLORAAAAAA,LINETHICK2;
    {盤龍駙鳳}
    望喜:IF(PERIOD=0,小差%*100+2500,DRAWNULL),COLOR000000,LINETHICK1;
    IF(PERIOD=0 AND TJA>1,小差%*100+2500,DRAWNULL),COLORFFFF00;
    盤龍:IF(PERIOD=0,大差%*100+2500,DRAWNULL),COLOR00FFFF,LINETHICK2;
    STICKLINE(PERIOD=0 AND FILTER(T,239)>0,12000*KL,-5000*KL,1,0),COLORWHITE;
    A7:=C-REF(C,1);
    A8:=IF(((TJA<2 OR PERIOD!= 0) OR PERIOD!= 0),5000*EMA(EMA(A7,11),11)/EMA(EMA(ABS(A7),11),11),DRAWNULL),LINETHICK2;
    SHORT:=3; LONG:=19;
    RMA:=EMA(CLOSE,SHORT);
    NMA:=EMA(CLOSE,LONG);
    UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1),LLV(L,BARSLAST(CROSS(NMA,RMA))+1),H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1),HHV(H,BARSLAST(CROSS(RMA,NMA))+1),0);
    DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(RMA,NMA))+1),HHV(H,BARSLAST(CROSS(RMA,NMA))+1),L=LLV(L,BARSLAST(CROSS(NMA,RMA))+1),LLV(L,BARSLAST(CROSS(NMA,RMA))+1),0);
    買進:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
    賣出:=(HHV(A8,2)=HHV(A8,7) OR A8=HHV(A8,2)) AND DOWN>REF(UP,1);
    DRAWICON(買進=0,A8*1.1,1);
    DRAWICON(買進=1,A8,23);
    RV:=((CLOSE-LLV(LOW,5))/(HHV(HIGH,27)-LLV(LOW,27))*200-60)*100*KL;
    VAR4:=SMA(RV,3,1);
    VAR5:=SMA(VAR4,3,1);
    龍K:IF(((TJA<2 OR PERIOD!= 0) OR PERIOD!= 0),SMA(L1,3,1)*100*KL,DRAWNULL),COLORRED;
    鳳D:IF(((TJA<2 OR PERIOD!= 0) OR PERIOD!= 0),SMA(龍K,3,1),DRAWNULL),COLORBBFFBB;
    N1:=7;
    LC:=REF(CLOSE,1);
    X:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*1000,COLORMAGENTA;
    牛相:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,1);
    TJ1:=X=牛相;
    TJ2:=X<REF(X,1);
    DRAWICON(TJ1 AND TJ2,X,1);
    DRAWTEXT(TJ1 AND TJ2,X,'買')COLORRED;
    VAR1R:=(HIGH+LOW+CLOSE*2)/4;
    VAR2R:=EMA(VAR1R,21);
    VAR3R:=STD(VAR1R,21);
    VAR4R:=((VAR1R-VAR2R)/VAR3R*100+200)/4;
    VAR5R:=(EMA(VAR4R,5)-25)*1.56;
    AK:=EMA(VAR5R,2)*1.22;
    AD1:=EMA(AK,2);
    拐點:=CROSS(AD1,AK);
    DRAWTEXT(拐點,X,'變盤');
    VAR6R:=((C+2*L)/3-LLV(L,8))/(HHV(H,8)-LLV(L,8))*100;
    VAR7R:=SMA(VAR6R,2,1);
    DRAWTEXT(X>50 AND X<=80 AND CROSS(X,VAR7R),X,'追'),COLORYELLOW;
    DRAWTEXT(CROSS(X,70) AND VAR7R<15,X,'底'),COLORRED;
    DRAWTEXT(CROSS(X,85) AND VAR7R<10,X,'漲'),COLORMAGENTA;
    DRAWTEXT(VAR7R<11 AND VAR7R>REF(VAR7R,1),VAR7R,'漲'),COLORRED;
    DRAWTEXT(CROSS(X,70) AND VAR7R<20,X,'底'),COLORRED;
    DRAWTEXT(ISLASTBAR,X,' 金牛判勢'),COLORRED;

    那位朋友有通達信趨勢買賣的這個指標公式???幫忙傳一個好嗎?謝謝!

    DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:EMA(DIFF,9),COLORFFFF00;
    MACD:(DIFF-DEA)*2;
    STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLORRED;
    STICKLINE(MACD>=0 AND MACD<=REF(MACD,1),0,MACD,1,0),COLORGREEN;
    STICKLINE(MACD<=0 AND MACD>=REF(MACD,1),0,MACD,1,0),COLORFF00FF;
    STICKLINE(MACD<=0 AND MACD<=REF(MACD,1),0,MACD,1,0),COLOR00FFFF;
    多轉空:=((((LLV(MACD,4)>0) AND (MACD<REF(MACD,1))) AND (REF(MACD,1)>REF(MACD,2))) AND (REF(MACD,2)>REF(MACD,3)));
    空轉多:=((((HHV(MACD,4)<0) AND (MACD>REF(MACD,1))) AND (REF(MACD,1)<REF(MACD,2))) AND (REF(MACD,2)<REF(MACD,3)));
    DRAWICON(多轉空,MACD,2);
    DRAWICON(空轉多,MACD,1);
    低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
    DRAWTEXT(低位金叉,DEA,' 低位金叉'),COLORFF00FF;
    {STICKLINE(低位金叉,0,0.3,8,0),COLORYELLOW;
    DRAWICON(低位金叉,0.3,1)};
    JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
    二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
    STICKLINE(二次金叉,0,0.2,2,0),COLORFF00FF;
    DRAWTEXT(二次金叉,DEA*1.06,'二次金叉'),COLORRED;
    A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
    底背離:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
    {STICKLINE(底背離,0.5,0.8,2,0),COLORRED};
    DRAWLINE(A1=0,DEA,底背離,DEA,0),COLORRED,LINETHICK3;
    A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
    頂背離:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
    DRAWLINE(A2=0,DEA,頂背離,DEA,0),COLORBLUE,LINETHICK3;
    {
    選股 低位金叉
    DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:=EMA(DIFF,9);
    MACD:=(DIFF-DEA)*2;
    低位金叉:CROSS(DIFF,DEA) AND DIFF<-0.1;
    選股 二次金叉
    DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:=EMA(DIFF,9);
    JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
    二次金叉:CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
    };
    看看這個有用嗎,沒用再聯系我。我給你解決

    請高手把通達信趨勢買賣指標改寫成選股公式,要求能選出股價在紅線下面的股,

    我用三天了,,選出的照樣跌

    通達信主力買賣指標怎么看?

    白線為短期主力運作軌跡,黃線為中期主力運作軌跡,紫線為長期主力運作軌跡。 1、主力進出指標的白線向上突破黃線、紫線且三線向上發散,表示主力有效控盤,可逢底介入,持股待漲。 2、主力進出指標的白線上漲過快遠離黃、紫線,出現較大乖離,表示短線獲利籌碼較多,宜注意控制風險,可適當賣出。 3、當白線回落至黃、紫線處受支撐時,而黃紫線發散向上,表示上升趨勢未改,前期股價回落僅是途中的回調,可適量跟進。 4、主力進出三線“死亡交叉”,盤口呈空頭排列,投資者宜盡快出局。 5、主力進出三線相近并平行向下時,表明主力尚未進場或正在出貨,此時不宜介入。 6、主力進出是一種趨勢指標,但趨勢改變信號有時會出現滯后現象,此時就要用主力買賣指標加以配合使用。
    滿意請采納

    通達信指標公式源碼資金博弈終結版

    內容來自用戶:孫玲玲

    本指標由多個指標公式組合,經多次測試修改,源碼分享,附近期實戰截圖。VAR1:=(CLOSE*2+HIGH+LOW)/4;VAR2:=EMA(VAR1,13)-EMA(VAR1,34);VAR3:=EMA(VAR2,5);SHZJX:=(-2)*(VAR2-VAR3)*3.8;ZLZJX:=2*(VAR2-VAR3)*3.8;STICKLINE(ZLZJX>0,0,ZLZJX*10,3.2,4),COLORRED;STICKLINE(ZLZJX<0,0,ZLZJX*10,3.2,4),COLORGREEN;
    VAR4:=EMA(EMA(CLOSE,9),9);控盤:=(VAR1-REF(VAR4,1))/REF(VAR4,1)*30;A10:=CROSS(控盤,0);無莊控盤:IF(控盤REF(控盤,1) AND控盤>0,控盤,0),COLORRED,NODRAW;VAR5:=100*WINNER(CLOSE*0.95);高度控盤:IF(VAR5>50 AND COST(80)0,控盤,0),COLORFF00FF,NODRAW;散戶資金線:SHZJX,COLORGREEN;主力資金線:ZLZJX,COLORYELLOW,LINETHICK2;XA:=CROSS(主力資金線,散戶資金線),COLORMAGENTA;建倉:IF(XA,4,0),LINETHICK1,COLORMAGENTA;飛龍在天:=EMA(COST(80),13);啟動:主力資金線>REF(主力資金線,1) AND主力資金線>-1.3 AND C/REF(C,1)>1.05 AND C>飛龍在天AND高度控盤>1,COLORRED;主力出貨:IF(控盤0,控盤,0),COLORCYAN,NODRAW;清倉:CROSS(散戶資金線,主力資金線),COLORGREEN;
    STICKLINE(控盤<0,控盤,0,2.8,0),COLOR00AAFF;STICKLINE(控盤<0,控盤,0,1.5,0),COLOR00CCFF;STICKLINE(控盤REF(控盤,1) A

    資金博弈指標 通達信公式源代嗎

    {資金博弈}
    V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
    HY1:=REF(EMA(V1,3),1);
    多空趨勢:=(MA((CLOSE - HY1) * 28,2))*0.1;
    操盤4:STICKLINE(多空趨勢>=0 AND 多空趨勢>=REF(多空趨勢,1),24,24+多空趨勢,1.5,0),COLORRED;
    減倉4:STICKLINE(多空趨勢>=0 AND 多空趨勢< REF(多空趨勢,1),24,24+多空趨勢,1.5,0), COLORRED;
    反彈4:STICKLINE(多空趨勢<0 AND 多空趨勢>=REF(多空趨勢,1),24,22+多空趨勢,1.5,0),COLORGREEN;
    尋底4:STICKLINE(多空趨勢<0 AND 多空趨勢< REF(多空趨勢,1),24,24+多空趨勢,1.5,0),COLORGREEN;
    DRAWTEXT(ISLASTBAR=1,IF(多空趨勢>=0,22,22.3),' 多空'),COLORWHITE;
    換手:=V*100/CAPITAL;
    主力:=MA(換手,4);
    大戶:=MA(換手,9);
    中戶:=MA(換手,17);
    散戶:=MA(換手,34);
    均量:=(主力+大戶+中戶+散戶)/4;
    成交量:V,COLORWHITE,NODRAW;
    主力能量:(主力-均量)COLORMAGENTA,NODRAW;
    大戶能量:(大戶-均量)COLORYELLOW,NODRAW;
    中戶能量:(中戶-均量)COLORLIBLUE,NODRAW;
    散戶能量:(散戶-均量)COLORBLUE,NODRAW;
    操盤:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORRED;
    減倉:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORYELLOW;
    反彈:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORGREEN;
    尋底:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORGREEN;
    DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,14.4,14.6),' 機構'),COLORMAGENTA;
    操盤1:STICKLINE(大戶能量>=0 AND 大戶能量>=REF(大戶能量,1),9.6,9.6+大戶能量,1.5,0),COLORRED;
    減倉1:STICKLINE(大戶能量>=0 AND 大戶能量< REF(大戶能量,1),9.6,9.6+大戶能量,1.5,0),COLORYELLOW;
    反彈1:STICKLINE(大戶能量<0 AND 大戶能量>=REF(大戶能量,1),9.6,9.6+大戶能量,1.5,0),COLORGREEN;
    尋底1:STICKLINE(大戶能量<0 AND 大戶能量< REF(大戶能量,1),9.6,9.6+大戶能量,1.5,0),COLORGREEN;
    DRAWTEXT(ISLASTBAR=1,IF(大戶能量>=0,9.6,9.8),' 大戶'),COLORYELLOW;
    操盤2:STICKLINE(中戶能量>=0 AND 中戶能量>=REF(中戶能量,1),4.8,4.8+中戶能量,1.5,0),COLORRED;
    減倉2:STICKLINE(中戶能量>=0 AND 中戶能量< REF(中戶能量,1),4.8,4.8+中戶能量,1.5,0),COLORRED;
    反彈2:STICKLINE(中戶能量<0 AND 中戶能量>=REF(中戶能量,1),4.8,4.8+中戶能量,1.5,0),COLORGREEN;
    尋底2:STICKLINE(中戶能量<0 AND 中戶能量< REF(中戶能量,1),4.8,4.8+中戶能量,1.5,0),COLORGREEN;
    DRAWTEXT(ISLASTBAR=1,IF(中戶能量>=0,4.8,5),' 中戶'),COLORLIBLUE;
    操盤3:STICKLINE(散戶能量>=0 AND 散戶能量>=REF(散戶能量,1),0,散戶能量,1.5,0),COLORRED;
    減倉3:STICKLINE(散戶能量>=0 AND 散戶能量< REF(散戶能量,1),0,散戶能量,1.5,0),COLORRED;
    反彈3:STICKLINE(散戶能量<0 AND 散戶能量>=REF(散戶能量,1),0,散戶能量,1.5,0),COLORGREEN;
    尋底3:STICKLINE(散戶能量<0 AND 散戶能量< REF(散戶能量,1),0,散戶能量,1.5,0),COLORGREEN;
    DRAWTEXT(ISLASTBAR=1,IF(散戶能量>=0,-0.3,0.3),' 散戶'),COLORBLUE;
    JZ:=V/(ABS(主力能量)+ABS(大戶能量)+ABS(中戶能量)+ABS(散戶能量));{4,9,17,34日換手偏離值均分成交量}
    ZLCJ:=JZ*ABS(主力能量);{4日換手偏離均量值換算當日成交量}
    DHCJ:=JZ*ABS(大戶能量);{9日換手偏離均量值換算當日成交量}
    ZHCJ:=JZ*ABS(中戶能量);{17日換手偏離均量值換算當日成交量}
    SHCJ:=JZ*ABS(散戶能量);{34日換手偏離均量值換算當日成交量};
    換手率:VOL/CAPITAL*100,LINETHICK0;
    機構量:=ZLCJ,COLORMAGENTA,NODRAW;
    大戶量:=DHCJ,COLORYELLOW,NODRAW;
    中戶量:=ZHCJ,COLORLIBLUE,NODRAW;
    散戶量:=SHCJ,COLORBLUE,NODRAW;
    股票公式專家團為你解答,希望能幫到你,祝投資順利。